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このマニュアルはとろろこんぶ電子印鑑「日付印ぺったん」のインストール方法及び操作方法
を記述したユーザズマニュアルです。実習マニュアルと合わせて読んでいただければ日付印ぺ
ったんの基本的な操作をマスターすることができます。なお、青字部分は今回のバージョンア
ップで追記した部分です。 
 

１．はじめに 

このソフトウェアは電子的に日付印（会社でよく使うあの３段で日付が中段にあるはんこ）を
押印し、パソコン上で電子的に決済をするソフトウェアです。日付は西暦だけでなく和暦の表
示も可能です。 
 
 
 
 
 
 
 
 
 
 このソフトウェアではＯＬＥというテクノロジーを使って、日付印をデータに埋め込みます。
例えば、ワードや一太郎などのＯＬＥ対応のワープロソフトには、オブジェクトの挿入という
機能が用意されていますが、それを使って日付印ぺったんのオブジェクトを文書中に埋め込む
ことができます。  
 ただし、押印の際にはﾊﾟｽﾜｰﾄﾞを入力しなければなりません。このﾊﾟｽﾜｰﾄﾞ機能によってﾊﾟｽﾜ
ｰﾄﾞを知っている人しか押印できないようになっており、電子承認が可能になるわけです。  
 押印時には文書番号、承認者名、日付、承認者の所属、承認項目などがオブジェクトに埋め
込まれます。また、承認履歴がログファイルに吐き出されますので、文書の承認履歴管理が可
能になります。  
 
 
1-1. 動作環境 

このソフトウェアは次のOS上で動作します。 

l Windows Vista (RC1) 
l Windows2000 
l WindowsXP 
l Windows98 SE 
l Internet Explorer 5.0 以降が組み込まれた Windows98 

 
注意) Windows９８ でも動作しますが、リソースメモリーが不足するなど動作不安定になることがあります。
Windows９８ での使用はお勧め出来ません。 
Windows95では動作しませんのでご注意ください。 
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1-2．使用ライセンスと体験版 
 
日付印ぺったんを使用するにはライセンスが必要です。 
ライセンスには企業向けの基本ライセンスと個人向けのパーソナルライセンスがあります。 
 
基本ライセンス（企業向け） 
基本ライセンスでは、上段及び下段の文字を自由に設定できます。 
企業内で用いる場合は基本ライセンスをご購入ください。 
 
パーソナルライセンス(個人向け) 
パーソナルライセンスでは上段と下段の文字が固定となります。 
上段に所属名などを指定した場合、所属が変更になってもライセンスの再発行はしませんので
企業内で用いる場合は基本ライセンスをご購入ください。 
 
体験使用 
日付印を構成する文字数の合計が全角２文字（半角４文字）以内であれば体験使用ができます。 
上記制限を越える場合はパーソナルライセンスをご購入ください。 
 
日付印ぺったんは２つの実行モジュール、管理ツール ptmgr.exe とメインモジュール 
pettanin.exe で構成されます。 
 
モジュール名 概要 ライセンスについて 
ptmgr.exe ぺったんマネージャ。日

付印を管理するツール。 
 

ライセンスはこの管理ツールに設定します。 
ライセンスを設定しなくても体験使用ができます。 

pettanin.exe 日付印ぺったんの本体
モジュールです。 

ライセンスの設定はありません。 

 
ライセンスについて詳しくは次のサイトをご覧ください。 
 

http://homepage3.nifty.com/tororokonbu/hanko_price.html 
 
 
ライセンスがなくても体験使用は可能ですので、次のインストールへ進んでください。
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２．インストール 

2-1. インストールの準備 

インターネット上からダウンロードなどして入手した場合はファイル名が pettan****.exe あ
るいは pettan****.lzh, pettan****.zip になっております。いずれも圧縮ファイルですので解
凍する必要があります。 
pettan****.exe の場合は自己解凍ファイルですので、このファイルをダブルクリックするな
どして起動すれば解凍することが出来ます。pettan****.lzh, pettan****.zipの場合は解凍ツー
ルを用いて解凍してください。 
解凍によって インストーラ setup.exe が生成されます。 
 
注意）日付印ぺったんが既にインストールされている場合は日付印ぺったんインデックスファイル 
(index.dat)やプロファイルをバックアップしておいてください。インストーラがこれらのファイルを上書きする場
合があります。上書きされると、登録済みの承認印やプロファイルが削除されますので注意して下さい。 
 

2-2．インストール 

2-2-1.インストール 
 

  
図 2.1 WindowsXP 制限ユーザで setup.exe を実行
するとこの警告が表示される。Administrator 権限で
インストールする必要があるため、「次のユーザとし
てプログラムを実行する」を選択し、管理権限のある
ユーザで実行する。 

図2.2 Windows2000Powerユーザでsetup.exe を実
行するとこの警告が表示される。PowerUser 権限で
あればインストールできるため、そのままボタン
「OK」をクリックして先に進む。 

 
インストールは自己解凍モジュールsetup.exe を実行するだけです。 
 
手順０）管理権限のあるユーザ（Administrator/PowerUser）で Windows にログインしてく
ださい。 
 
手順１）  setup.exe をエクスプローラ上でダブルクリックするなどして実行します。 
 
参考 1）WindowsXP の制限ユーザでインストールを開始した場合、図２．１の警告ダイアローグが表示され
ます。制限ユーザではインストールできませんので「次のユーザとしてプログラムを実行する」を選択し、管
理権限のあるユーザで実行してください。 
 
参考 2）Windows2000 の Power ユーザでインストールする場合、図２．2 の警告ダイアローグが表示されま
す。Powerユーザであればインストール可能ですので、ボタン「OK」をクリックして先に進みます。 
 
参考 3) Windows Vista の場合、「不明なプログラムがお使いのコンピュータへのアクセスを要求していま
す。」と表示されます。「許可(A)」を選択してください。 
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図 2.3 インストール先を指定 図 2.4 言語選択ダイアローグ 
 
 
手順２）  インストール先を聞いてきますのでインストール先を設定します。（図2.3） 
インストール先のデフォルト値は c:¥hanko ですが、任意に変更できます。 
 
注意）日付印ペッタンが既にインストールされている場合はぺったんインデックスファイル (index.dat)を上書
きするか聞いてきますので上書きしないようにします。  
上書きすると登録済みの日付印が削除されますので注意して下さい。 
 
手順４）言語の選択 
言語選択ダイアローグが表示されたら、使用する言語を選択して、ボタン「OK」をクリック
します。(図 2.4) 
 
 

 

 

図 2.5 日付印ぺったんが起動する。 図 2.6 インデックスファイルが見つからない場合は警告が表
示される。 

 
インストール実行後、自動的に日付印ペッタンの実行モジュール pettanin.exeが起動します。
（図 2.5）この起動は必要な情報をレジストリに書きこむためです。 
 
注意） Windows Vista(RC1) の場合、pettanin.exe を実行してもレジストリへの書き込みは実行されないよう
です。再インストールの際は setup.exe を実行してください。 
 
手順３）  メニュー「File」->「End」を選び終了させます。 
以上でインストールは終了です。  
 
注意） Windows Vista(RC1) の場合、インストール終了後、「このプログラムは正しくインストールされなかっ
た可能性があります。」と表示されます。「このプログラムは正しくインストールされました。」を選択します。 
 
参考）インストールが終了すると、インデックスファイルパス、言語が パーソナルドキュメントフォルダ下の
hanko.ini に書き込まれます。パーソナルドキュメントフォルダの場所は次の通りです。 
 
Windows Vista (RC1) c:¥ユーザー¥ユーザ名¥ドキュメント¥hanko.ini 
WindowsXP  C:¥Documents and Settings¥ユーザ名¥My Documents¥hanko.ini 
Windows2000  C:¥Documents and Settings¥ユーザ名¥My Documents¥hanko.ini 
Windows98  c:¥My Documents¥hanko.ini 



とろろこんぶシステム工房 

 
6 

 

hanko.ini の例 
[MAIN] 
PettanDataFile=c:¥hanko¥ptdata¥index.dat 
Lang=Japanese 
 
インデックスファイルが存在しない場合、見つからない場合は、警告メッセージ Warning 1320
が表示されます。(図 2.６) この警告が表示された場合はボタン「はい」をクリックし、イン
デックスファイルパスを設定してください。デフォルトのインデックスファイル名はindex.dat 
です。詳しくは「２-2-2. インデックスファイルパスの設定」を参照ください。 
 
以上でインストールは完了です。初めてお使いになる方は実習マニュアルに従って一連の操作
を習得してください。 
 
注意） インストール時のログインユーザ以外でログインし、初めて日付印ぺったんを起動した場合、言語選
択ダイアローグが起動します（図２－４）。これは、ログインしたユーザのパーソナルドキュメントフォルダーが
インストール時と異なるためhanko.ini が見つからないためです。 
なお、日付印ぺったんを使用するユーザはAdministrator/PowerUser権限を持っている必要はありません。 
 

2-2-2. インデックスファイルパスの設定 
日付印ぺったんの印鑑情報はインデックスファイル(デフォルトファイル名 index.dat)に格
納されています。インデックスファイルのデフォルトパスは c:¥hanko¥ptdata¥index.dat で
す。このファイルが見つからない場合は警告メッセージ Warning 1320 が表示されます。(図 
２.６) 
 
「設定ダイアローグを表示しますか」という問いに対して[はい]を選択します。図2-8のよう
に、ファイル名設定ダイアローグが開きますので、インデックスファイル(index.dat)へのパス
を設定します。 
 
 

  
図 2-7 pettanin.exe を起動し、メニュー「設
定」を選択する。設定ダイアローグが開く。 

図 2-8 設定ダイアローグ 
インデックスファイルパス、言語などが設定でき
る。 

 
ＯＫボタンをクリックし、起動していたPettanin.exe を終了させます。メニュー「ファイル」
->「終了」あるいは[File]->[End]で終了します。 
 
ノート)インデックスファイル(デフォルトファイル名 index.dat)は、基本的にはどこに置いてもかまいません。サ
ーバに集中させてもいいし、ネットワーク上に分散させてもかまいません。フロッピーディスクやUSBフラッシ
ュに保っていてもかまいません。押印時にアクセスさえできれば、どこに置いてもかまいません。  
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2-2-3. インデックスファイルをファイルサーバ共有する場合 
ファイルサーバーを利用してインデックスファイルを集中管理することができます。 
ユーザの数が多い場合はファイルサーバ上にインデックスファイルを置き、各パソコンからは
このサーバ上のインデックスファイルを参照しに行くという構成をお勧めいたします。 
 

 

手順１）ファイルサーバ上に共有フォルダーを用意します。 
 
手順2） 日付印ぺったんをインストールしたフォルダ下のフォルダptdataを丸ごと手順１で
作成した共有フォルダーにコピーします。 
 
手順３）日付印ぺったんをインストールしたパソコンに実際に使用するアカウントでログイン
します。Administrator/Poweruser権限を持っている必要はありません。 
 
手順４）  日付印ぺったん pettanin.exe を起動し、メニュー「オプション」->「設定」を起
動し、インデックスファイルのパス設定を行ってください。（図2-7,図2-8） 

 

  
図２－９ インデックスファイルパスの設定は管理ツ
ール「ぺったんマネージャ」でも行える 

図２－１０ インデックスファイルパス設定ダイアロー
グ。ネットワークドライブ上のインデックスファイルをし
ていることも出来る。 

 

図２－１０の場合、 Asus1 はサーバのホスト名で group02.dat がインデックスファイル
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名になっています。 
 
参考）１つのインデックスファイルしか用いないと登録した全員が表示されてしまいます。ユーザ数が多い場
合はインデックスファイルの分割をお勧めいたします。インデックスファイル名およびそのフォルダー名は任
意に変更できます。 
 
参考）インデックスファイルパスの設定情報はパーソナルドキュメントフォルダ下のhanko.ini に保存されま
す。パソコンの台数が多い場合はこのファイルを他のパソコンにコピーしてしまうというてっとり早い方法もあ
ります。 
 
2-3. インストールされるファイルとフォルダー 
自己解凍により解凍生成されるファイルとフォルダーを下表に示します。 
ファイル名 説明 

pettanin.exe 日付印ぺったんの実行モジュール 
ptmgr.exe 日付印ぺったん管理ツール 
index.dat ぺったんインデックスファイル 
*.ptn ぺったんファイルサンプル 
tkprf_ptn_***.xml プロファイル（パラメータが入っています。） 
 
フォルダ名 説明 

pt_data 実習用のサンプルインデックスファイルが入っています。 
インストール中、モジュール選択ダイアローグで「サンプルデータ」
をチェックするとインストールされます。 

 
 
2-4. Excel/Word ツールバー 
日付印ぺったんを便利に使うExcel/Word/PowerPoint ツールバーが用意されています。 
下記ホームページからダウンロードしてご利用ください。 
 
ワードツールバー 
http://homepage3.nifty.com/tororokonbu/hanko_wordtoolbar.html 
 
エクセルツールバー 
http://homepage3.nifty.com/tororokonbu/hanko_exceltoolbar.html 
 
パワーポイントツールバー 
http://homepage3.nifty.com/tororokonbu/hanko_pptoolbar.html 
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実習１ インストール 

実習 1-1.日付印ぺったんのインストール 
「日付印ぺったん」をインストールしてください。 
 
実習 1-2．サンプル登録ユーザ 
日付印ぺったん に添付されているインデックスファイル index.dat に初期登録されている日
付印は次のとおりです。この登録済みのサンプル日付印を用いて実習を進めていきます。 
 
日付印名 パスワード 上段の上 上段の下 下段 プロファイル 

情報システム部-鈴木 TEST  情報システム部 鈴木 Tkprf_ptn_default.xml 

情報システム部-鈴木（和暦） TEST  情報システム部 鈴木 Tkprf_ptn_default.xml 

安部 TEST  安 部 Tkprf_ptn_default.xml 

EDP-Suzuki TEST  EDP Suzuki Tkprf_ptn_default.xml 

TKSK情報システム部-鈴木 TEST TKSK 情報システム部 鈴木 Tkprf_ptn_test.xml 
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2-5.アンインストール 

日付印ぺったんにはアンインストーラを用意しておりません。 
インストール先のフォルダ(デフォルトでは c:¥hanko )ごと削除して頂ければディスクは開放
されますが、レジストリには情報が残ってしまいます。オブジェクト挿入時に表示されるオブ
ジェクトリストに「日付印ぺったん」が表示されてしまいます。気になるようでしたら下記の
手順でレジストリから日付印ぺったんに関する情報を削除してください。 
 

2-5-1. 日付印ペッタンのレジストリからの削除 
 日付印ペッタンをパソコンから完全に削除（アンインストール）するには、レジストリから
登録されたオブジェクトを削除する必要があります。削除にはレジストリエディタ(regedit.exe)
を用います。 
 
ノート）レジストリを破壊すると、Windows が起動できなくなるなど、重大な影響が出ることがあります。レジス
トリの操作は初心者の方にはお勧めできません。はんこがレジストリに登録されたままでも、問題ありません
ので、レジストリについてはそのままにしておくことをお勧めいたします。  
 

 

 
図 2-11 レジストリエディタを起動する 図 2-12 「日付印ぺったん」を検索する 
 
 
手順０）管理権限のあるユーザでWindows にログインします。 
制限ユーザではレジストリの操作は行えませんのでエラーとなります。 
 
手順１）  レジストリエディタ(regedit.exe)を起動します。（図2-11） 
スタートボタン ->「ファイル名を指定して実行」を選択し、regedit と入力し、OKボタンを
クリックします。レジストリエディタが起動されます。 
 
手順２)   削除するオブジェクトの検索（図2-12） 
「日付印ぺったん」を検索します。 
メニュー「編集」-> 「検索」を選択します。 
検索ダイアローグが開きますので、検索する値として「日付印ぺったん」を入力します。 日
付印ぺったんを英語で使用している場合は「Tororokonbu Pettan」で検索してください。 
検索時には検索対象に「データ」を含めます。 
検索には数分かかることがあります。 
HKEY_CLASS_ROOT￥CLSID¥{36593300-C9D9-101C-A998-FE1AF6F9D52A} が検索されるはず
です。 
 
参考） 検索せずに HKEY_CLASS_ROOT￥CLSID¥{36593300-C9D9-101C-A998-FE1AF6F9D52A}を直
接指定してもよい。 
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手順３）  削除 
36593300-C9D9-101C-A998-FE1AF6F9D52Aを選択し、マウス右クリックで削除をクリックし
ます。 
 
注意）ここで、「キーの削除エラー」となるようでしたら、管理権限の無いユーザで Windows にログインしてい
る可能性があります。管理権限のあるユーザでWindows にログインしなおしてください。 
 
「このキーとそのサブキーをすべて削除しますか？」というダイアローグが表示されますので、
ボタン「はい」をクリックします。 
 
手順４）  HKEY_CLASS_ROOT¥ Pettan.Documentの削除 
検索操作をもう一度行います。メニュー「編集」-> 「次を検索」を選択します。この検索に
は数分かかるかもしれません。¥ Pettan.Document が検索されるはずです。 手順３と同様の方法で
削除してください。  

 

 
手順５）  レジストリエディタを閉じてください。  
メニュー「ファイル」-> 「レジストリエディタの終了」 

 

2-5-2．ファイルの削除 
日付印ぺったんに関わるファイルをインストール先(デフォルトでは c:¥hanko )のフォルダご
と削除してください。  
以上でアンインストールは完了です。 
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３．押印 

 
 

図 3-1 OLE対応アプリケーションにはオブジェクトの
挿入メニューがある。 

図 3-2 オブジェクトの挿入ダイアローグから「日付
印ぺったん」を選択する。 

 

3-1. 日付印ぺったんオブジェクトの挿入 
 
MS-WordやMS-Excel などOLE対応アプリケーションにはOLEオブジェクトの挿入機能が
あります。電子印鑑 「日付印ぺったん」はこの OLEオブジェクトとして挿入されます。 
 
MS-Word の場合の「日付印ぺったん」オブジェクトの挿入操作手順は次のようになります。
MS-Excel など他の OLE対応アプリケーションでも操作は殆ど同じです。 
 
手順１）MS-Wordなど OLE対応アプリケーションの文書が開いた状態にします。 
 
手順２）メニュー「挿入」->「オブジェクト」を選択します。（図 3-1） 
 
手順３）「オブジェクトの種類」リストボックスから「日付印ぺったん」あるいは「Tororokonbu 
Pettan」を選び、ＯＫボタンをクリックします。（図 3-2） 
 
「ぺったんオブジェクト」が挿入されます。（図 3-3） 
 

  
図 3-3 日付印ぺったんオブジェクトが挿入され、ア
クティブとなっている。メニューが日付印ぺったんの
メニューに入れ変わっている。 

図 3-4 オブジェクト以外の部分をクリックすればオ
ブジェクトがアクティブな状態は解除され、メニュー
は MS-Word のメニューに戻る。日付印の印影は未
押印のため破線になっている。 
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3-2. 押印ダイアローグ 
「日付印ぺったん」オブジェクトがアクティブな状態ではメニュー及びツールバーは日付印ぺ
ったんにメニュー/ツールバーに入れ替わっています。 
 

メニュー「承認」->「承認押印」を選択するか、ボタン  をクリックすることにより押印ダ
イアローグが表示します。 

 
図 3-5 押印ダイアローグ 
 
 項目 説明 
① 日付印選択 日付印ぺったんを選択します。選択するとその日付印ぺったんに登録

されている上段(所属),下段(名前)が下に表示されます。 
② 日付印表示 日付印ぺったんを選択するとその日付印ぺったんに登録されている上

段(所属),下段(名前)が表示されます。 
日付はこのダイアローグボックスが開いたときの日付が表示されます。 
日付は変更（エディット）することができますが、上段(所属),下段(名
前)は変更できません。 

③ プロファイル 設定されているプロファイルが表示されます。 
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④ 承認情報 文書番号、承認者名、所属、承認日、承認項目を入力することができ
ます。入力されたこれらの情報はぺったんオブジェクト（ＯＬＥオブ
ジェクト）に挿入されます。印影自体には表示されません。押印情報
確認機能で表示できます。 
承認者名、所属、承認項目については、前回承認時に入力したもの
(hanko.iniに保持)が表示されます。なお、この承認者名、所属、承認
項目は編集（エディット）できます。 
承認日にはこのダイアローグボックスが開いたときの日付と時刻が表
示されます。 

⑤ 色 赤または黒が選択できます。 
⑥ パスワード 承認パスワードを入力します。「鈴木」のパスワードは TEST で登録

されています。ここでは TESTを入力します。  
パスワードは大文字ですが、小文字で入力すると自動的に大文字に変
換されます。 また、パスワードを保存をチェックしておけば、次回の
承認時にはパスワードが自動的に挿入されます。  
 パスワードは Windows のログインユーザ毎に暗号化されて保持さ
れます。つまり、パスワードを保存したときの Windows ユーザと異
なるユーザで Windows へログインした場合はパスワードは自動設定
されません。 

⑦ ログイン名 Windows へのログインユーザ ID が表示されます。この ID は日付印
ぺったんオブジェクトへ押印時の情報として格納されます。 

⑧ インデックス
ファイルパス 

インデックスファイルパスが表示されます。 

 
押印ボタンをクリックすれば押印されます。(図 3-6) 

 

  
図 3-6 押印した状態ではオブジェクトはアクティブ
なまま。メニューは日付印ぺったんのものになって
いる。 

図 3-7 オブジェクト以外の部分をクリックすることに
より日付印ぺったんオブジェクトはアクティブでなく
なり、メニューはMS-Word のものに戻る。 

 
日付印ぺったんオブジェクト以外の部分をクリックすれば、MS-WORD ﾞのメニューﾞに戻り
ます。(図 3-7) 
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実習２．押印 

日付印ぺったんにサンプルとして標準添付されているインデックスファイル index.dat を用い
て、「情報システム部の鈴木さん」の日付印を押印します。 
 
手順１）MS-Word を起動します。 
 
手順２）「3-1. 日付印ぺったんオブジェクトの挿入」に従い、日付印ぺったんオブジェクトを
挿入します。（図 3-3） 
 

手順３） メニュー「承認」->「承認押印」を選択するか、ボタン  をクリックしてくださ
い。 

 
承認ダイアローグが開きますので、日付印選択リストから「情報システム部-鈴木」を選択し、
承認情報(文書番号、承認者名、所属、コメント)を適当に記入します。日付は自動的に入力さ
れます。パスワードには"TEST"を入力します。（図 3-5） 
 
手順４）押印ボタンをクリックします。 
押印ダイアローグは閉じ、押印されます。（図 3-6） 
日付印ぺったんオブジェクト以外の部分をクリックすれば、MS-WORD ﾞのメニューﾞに戻りま
す。（図 3-7） 
 
以上で押印についての説明は終わりです。問題なく押印できましたでしょうか。  
次は、押印時に入力した承認情報を確認します。  
 
手順５）この文書を適当な名前で保存して、MS-WORDを一旦終了します。 
 
ノート）この実習では手動でオブジェクトリストから日付印ぺったんを選択するという少々煩雑な操作を行い
ましたが、MS-WORD,MS-EXCEL にはボタン一発で挿入できる便利なツールバーが用意されています。
「2-4. Excel/Word ツールバー」を参照してください。 
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４．押印情報の確認 

 

  

図 4-1 押印情報を確認するためには日付印ぺ
ったんオブジェクトをアクティブにする必要があり
ます。 

図 4-2 押印情報が表示されます。 

 

日付印ぺったんオブジェクトには押印情報が保持されています。この押印情報を確認する機能
が日付印ぺったんには備わっています。 
 
手順１）日付印ぺったんオブジェクトをダブルクリックし、アクティブにします。(図 4-1) 
 

手順２）メニュー「承認」->「承認確認」を選択するかボタン    をクリックします。  

押印情報確認ダイアローグが開き、押印時に入力した情報が確認できます。(図 4-2) 
 
また、押印に使われたコンピュータの名前、押印時の Windows ログインユーザ ID も確認で
きます。 
 
ノート）日付印ぺったんオブジェクトを他の文書からコピーしてきても、文書番号が違うので不正が見抜くこと
ができます。また、押印に使われた日付印ぺったんのバージョン、ライセンス ID もオブジェクトに保持され、
確認できますので正規ライセンスを購入していないユーザによる押印と区別ができ、セキュリティーは守られ
ます。なお、ライセンスIDには企業名を設定することができます。 
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実習３．押印情報の確認 

 

実習２で挿入した日付印ぺったんオブジェクトの承認情報を確認します。  
 
手順０）実習２で保管したWORD文書を開きます。 
 
手順１）はんこオブジェクトをダブルクリックします。日付印オブジェクトがアクティブにな
ります。(図 4-1) 
メニュー及びツールバーボタンは日付印ぺったんのものに入れ替わっています。  

手順２）メニュー「承認」->「承認確認」を選択するかボタン  をクリックします。  

承認確認ダイアローグが開き、実習２で挿入した承認情報が確認できます。(図 4-2) 
 
手順３）ボタン「Close」をクリックし、押印情報ダイアローグを閉じ、ワードを終了します。 
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５．インデックスファイル index.dat 

日付印ぺったんの印影はインデックスファイル デフォルトファイル名 index.dat とぺったん
ファイル（***.ptn）とで管理されます。 
 
参考)このインデックスファイルはユーザ毎に作成することもできますし、グループ毎に作成することもできま
す。つまり、１ユーザ１インデックスファイルでも、複数ユーザを１つのインデックスファイルにまとめて管理す
ることもできます。 インデックスファイルは INI 形式のテキストファイルです。メモ帳などで開いて内容を確認
することができます。 
 
[安部] 
Data=<Petfile>安部.ptn</Petfile> ---- 個々の日付印のファイル名 
<Profile>tkprf_ptn_default.xml</Profile> 
<Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>体験版</LicenseId><Hash>JC2JDWYW</Hash> 

Name=部  --- Ver5.6.1 では使用しません。過去のバージョンとの互換性維持の為。 
Section=<Up1><Text>安</Text></Up1><Up2><Text></Text></Up2>--- Ver5.6.1 では使用しません。 
Password1=JB5BSRNP 
Password2=TeHc[B 
Hash=By81nw  --- ぺったんファイル(この例では安部.ptn)の書き換え防止のハッシュコード 
 

インデックスファイル例 
ぺったんファイル例 安部.ptn 
<Pettan><Up1>安</Up1><Up2></Up2><Down>部</Down> 
<PettanID>0000-0000-0000-0000</PettanID><PHash>WYZJZDR6</PHash></Pettan> 
<Profile>tkprf_ptn_default.xml</Profile><Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>体験版</LicenseId><Hash>JC2JDWYW</Hash> 
 

ぺったんファイル例 ( 安部.ptn ) 
 
このファイルはテキストファイルですのでメモ帳などで開くことはできますが編集はできませ
ん。日付印ぺったん管理ツール ぺったんマネージャ ptmgr.exe を用いる以外の方法でこのフ
ァイルを書き換えますとセキュリティーエラーとなります。 
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６．日付印の登録、削除、修正 

日付印の登録、削除、修正は日付印ぺったん管理ツール ぺったんマネージャ(ptmgr.exe) で
行います。 
 
6-1. ぺったんマネージャ(ptmgr.exe) の起動 
ぺったんマネージャ(ptmgr.exe) の起動手順について説明します。  
 
手順１） ぺったんマネージャ ptmgr.exe をエクスプローラ上でダブルクリックするなどして
起動します。 
「プロダクト IDが一致しませんという警告メッセージが表示されます。（図 6-1） 
この警告はライセンス IDが設定されていないために表示されます。  
 
OKボタンをクリックします。日付印ぺったんマネージャが起動します。（図 6-2） 
 

 

 

 
図 6-1 ライセンスが設定されていないと警告が表示
されるが、体験使用は出来る。 

図 6-2 日付印ぺったん管理ツール ぺったんマネ
ージャ 
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6-2.．日付印の追加 
日付印を新たに登録するにはボタン「追加(Add)」をクリックします。 
ボタン「追加(Add)」をクリックすると追加ダイアローグボックスが開きます。 

 

 

 
各エディットボックスについて説明します。 
 
 エディットボックス 説明 
① Name(印名) 任意の名前を入力します。漢字も可能です。 
② パスワード 押印時に入力するパスワードを設定します。 

アルファベット半角で設定します。文字数に制限はありま
せん。 

③ 形状 横と縦のサイズを選択します。縦と横のサイズが異なる場
合は楕円になります。 

④ プロファイル プロファイルを設定します。プロファイルのデフォルトは
tkprf_ptn_default.xml です。特に必要がなければ変更する必要
はありません。 

⑤ インデックスファイル インデックスファイルが表示されます。 
⑥ 上段（所属） 上段は２段にすることができます。１段の場合は上段１に

入力します。 
⑦ 日付形式 日付の形式を選択します。 
⑧ 下段（名前） 下段は１段で入力します。 
   
印名、上段、下段を入力し、中段に入る日付のフォーマットを選択後、ボタン「追加(Add)」
をクリックします。基本ライセンス ID/キーされていない場合、つまり体験使用の場合やパー
ソナルライセンスの場合はぺったん ID設定ダイアローグが開きます。 
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上段と下段の文字合計が３文字以内であれば体験使用ができます。体験使用の場合はぺったん
IDは 0000-0000-0000-0000 にしてください。登録キーの入力は必要ありません。 
 
上段と下段の文字合計が３文字を越える場合は登録キーが必要になります。登録キーはパーソ
ナルライセンスご購入のユーザの方へお送りしております。  
 

6-3.．日付印の削除 

削除する日付印を選択します。 

 
 

ボタン[削除]をクリックします。 
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6-4．日付印の修正 
日付印を修正するには、修正する印名を選択して、ボタン「修正(Edit)」をクリックします。
修正ダイアローグボックスが開きます。 

 
 
 
エディットボックス 説明 
上段 1,上段２ 上段は２段にすることができます。１段の場合は上段１に入力します。 
日付形式 日付の形式を選択します。 
下段（名前） 下段は１段で入力します。 
形状 横と縦のサイズを選択します。縦と横のサイズが異なる場合は楕円にな

ります。 
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実習４ 自分の名前の登録 

実習２、３では日付印ぺったんに添付されているサンプルのインデックスファイル index.dat
を用いました。このインデックスファイルには既に「情報システム部 鈴木」のぺったんが登
録されています。  
次に、このインデックスファイルに自分の名前のぺったんを追加します。以下の説明では、名
前を「佐藤」と仮定していますが、自分の名前に置き換えて操作して下さい。 
 
ノート）体験モードでは、上段と下段の文字数の合計が全角２文字（半角４文字）に制限されています。 
この制限を越える場合には登録キーが必要になります。登録キーはパーソナルライセンスご購入の方にお
送りしております。 
 
手順１）管理ツール ptmgr.exe を起動します。 
エクスプローラ上で管理ツール ptmgr.exe をダブルクリックするなどして起動します。 
「プロダクト ID が一致しませんという警告メッセージが表示されます。この警告はライセン
ス IDが設定されていないために表示されます。 （図 6-1） 
 
OKボタンクリックし、「体験モード」で使用してください。 
管理ツールが起動されます。（図 6-2） 
 
手順３）ボタン「追加(Add)」をクリックします。 
追加ダイアローグが開きます。 
 
手順４）次のように入力します。（図 6-3） 
印名：佐藤       上段：佐       下段：藤            パスワード：TEST 
 
手順５）「Add(追加)」ボタンをクリックします。 
基本ライセンス IDが設定されていない場合はぺったん ID設定ダイアローグが開きます。 
 
手順６）ぺったん IDとして 0000-0000-0000-0000 を入力します。 
登録キーは空のままにします。（図 6-4） 
 

 

 

図 6-3 追加ダイアローグ 「佐藤」を登録してい
る。 

図 6-4 ぺったんID設定ダイアローグ 
体験使用の場合は0000-0000-0000-0000 を入力 
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図 6-5 体験使用の場合の表示 図 6-6 登録した日付印を押印する 
 
 
手順７）ボタン OKをクリックします。 
メッセージ「体験版ライセンスで登録しました。」が表示されれば、上段が「佐」、下段が「藤」
の日付印ぺったんが登録されてます。 （図 6-5） 
 
参考)ぺったんインデックスファイル index.dat をノートパッドなどのエディタで内容を確認してみてください。 
また、ファイル 佐藤.ptn が生成されているはずです。 
 
ノート）手順 3 で登録したぺったん「佐藤」の文字数は全角 2 文字ですので登録キーは必要ありませんでし
た。全角２文字までは登録キーは必要ありませんが、全角２文字を越える場合は登録キーが必要になりま
す。登録キーはパーソナルライセンスご購入の際にお送りしております。 
 
基本ライセンスをご購入いただくとライセンスIDをお送りしております。 
文字数にかかわらず、登録キーの入力は必要なくなります。また、ライセンスIDには企業名などを指定する
ことが出来ます。このライセンスIDはぺったんオブジェクトに挿入され、後で確認することができます。 
 
手順８）押印実習を参考に押印し、自分の名前が押印できることを確認してください。(図 6-6) 
 
注）文字サイズが小さすぎる場合は、フォントサイズを変更してください。フォントサイズはプロファイルを編
集することで行います。 
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実習５ 登録キーを用いての登録（全角２文字を越える場合） 

先の実習では「佐藤」を登録しました。 
今度は、「上段：情報システム部 下段：佐藤」を登録します。佐藤は全角２文字でしたので
登録キーは必要ありませんでしたが、今度は全角２文字を越えていますので登録キーが必要に
なります。 
 
「上段：情報システム部 下段：佐藤」のパーソナルライセンスを購入し、 
 
ぺったん ID 0000-1234-1234-1234  
登録キー 4JZUGEYA  
 
が送られてきたものと仮定します。  
 

 

 

図 6-7 上段：情報システム部 下段：佐藤 の登録 図 6-8 ぺったんIDダイアローグが開く 
 
 
手順１）管理ツール ptmgr.exe を起動します。 
 
手順２）ボタン「追加(Add)」をクリックします。追加ダイアローグが開きます。 
 
手順３）次のように入力します。(図 6-7) 
Name(印名)：佐藤＠情報システム部   上段 1： 情報システム部   下段：佐藤  
パスワード：TEST 
 
手順４）「Add(追加)」ボタンをクリックします。 
ぺったん ID設定ダイアローグが開きます。(図 6-8) 
 
注意） ぺったん ID 設定ダイアローグは基本ライセンスID を設定していない場合に表示されます。基本ら
センスIDをお持ちの方はライセンスIDの設定を行ってください。基本ライセンスIDの設定方法については
ユーザーズマニュアルの「基本ライセンスIDの設定」を参照ください。 
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図 6-9 ぺったんIDを入力する 図 6-10 押印してみる 
 
手順５）ぺったん ID 0000-1234-1234-1234 登録キー 4JZUGEYAを入力します。(図 6-9) 
 
手順６）「Add(追加)」ボタンをクリックします。これで上段が「情報システム部」、下段が「佐
藤」の日付印ぺったんが登録されました。  
 
参考)ぺったんインデックスファイル index.dat をノートパッドなどのエディタで内容を確認してみてください。 
ファイル「佐藤＠情報システム部.ptn」が生成されているはずです。確認してみてください。 
 
手順７）実習１を参考に押印し、佐藤＠情報システム部が押印できることを確認します。(図
6-10) 
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７．パスワードの変更 

パスワードの変更は日付印ぺったん pettanin.exe で行います。 
 

  
図 7-1 pettanin.exe を起動する。 図 7-2 メニ ュー  [Option] →  [Change 

Password ...]を選択します。 
 
パスワード変更手順は次の通りです。 
 
手順 1）pettanin.exe を起動します。(図 7-1) 
 
手順 2）メニュー [オプション] → [パスワードの変更 ...]を選択します。(図 7-2) 
パスワード変更ダイアローグが開きます。 
 
手順３）ぺったん選択リストボックスでパスワードを変更するぺったんを選択し、現在のパス
ワードと新しいパスワードを入力します。  
 
注）新しいパスワードは２つのエディットボックスに同じものを入力します。ミスタイプを防ぐためです。任意の
英数字で文字数に制限はありません。 
 
手順４） OKボタンをクリックします。 
「Password change Success!」が表示されればパスワード変更は完了です。(図 7-5) 
 

  
図 7-3 パスワード変更ダイアローグ 図 7-4 ぺったんを選択し、現在のパスワードと新し

いパスワードを入力 
 

 

 

図 7-5 パスワードが変更されるとこのメッセージが表示される。  
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実習６ パスワードの変更 

 
「情報システム部-鈴木」のパスワードを変更します。 
現在のパスワードには TESTを入力します。 
新しいパスワードには任意の英数字を入力します。 
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８．ライセンスIDとキーの設定方法 

ライセンスをご購入いただいた場合はライセンス ID/キーを設定する必要があります。 
ライセンスは日付印ぺったん管理ツール ぺったんマネージャに設定します。 
以下、設定手順について説明します。 
 

 

 
図 8-1 ライセンスが未設定だと警告が表示される。 図 8-2 ライセンスを設定するにはボタン[License 

Key]をクリックする。 
 
 
手順１）日付印ぺったん管理ツール ptmgr.exe を起動します。  
「プロダクト IDが一致しませんという警告メッセージが表示されます。「OK」をクリックし
ます。（図８－１）ボタンOKをクリックするとぺったんマネージャが開きます。 
 
手順２）ボタン「License Key…」をクリックします。（図８－２） 
 
手順３）基本ライセンス証書にかかれているプロダクト ID、ライセンス ID とライセンスキー
を入力し、OKボタンをクリックします。（図８－３） 
ライセンスボタン隣の表示が「体験」からライセンス IDに変わっています。（図８－４） 
 
 

 

 
図 8－3 ライセンスダイアローグ 図８－４ ライセンスIDが表示される 
 
 
 



とろろこんぶシステム工房 

 
30 

 

９. プロファイルについて 

日付印ぺったんは上段、日付（中段）、下段の文字列で構成されていますが、以前のバージョ
ンでは文字位置は固定で変更することができませんでした。フォントや文字数によっては円か
らはみ出したり、表示上問題になることがありました。この問題を解決するため、これらプロ
グラム中に固定値として存在していた座標情報をプロファイルとして外出しにし、ユーザが任
意に修正できるようにしました。 
 
最新バージョンの ver5.6.1.4 ではさらに区切り線や輪郭円を２重線に出来るようになってい
ます。さらに、太さを設定することができ、０（ゼロ）にすれば表示しないという設定も可能
になりました。また、文字のフォント情報もプロファイルで設定するようになりました。 
 
このプロファイル（デフォルトファイル名 tkprf_ptn_default.xml）はインデックスファイル 
index.dat と同じフォルダ（デフォルトではc:¥hanko）に置いてください。 
 
プロファイルはXMLファイルで、XMLエディタで修正することができます。XMLエディタ
が無い場合はメモ帳などのテキストエディタでも編集することが出来ます。 
  
Ver5.3.7.6 ではプロファイルは全てのはんこに共通で、ファイル tkprf_ptn_default.xml が
用いられましたが、Ver5.3.7.7 以降のバージョン ではぺったん毎に選択できるようになりま
した。 
プロファイルの選択は日付印ぺったん管理ツール(ぺったんマネージャptmgr.exe)で行います。
ぺったんマネージャを起動し、追加/修正ダイアローグではんこを追加/修正する際に指定しま
す。 
 下の例は追加ダイアローグの例です。 

 
 

図 プロファイルは管理ツールでの登録追加時に選択できる。 
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9-1．プロファイルの構造 
プロファイルはXMLファイルです。 
座標は左上が(0,0)でサイズは 100X100 です。 
下にデフォルトのプロファイル tkprf_ptn_default.xml を示します。 
 
tkprf_ptn_default.xml 
<?xml version="1.0" encoding="Shift_JIS" ?> 

<Profile>  

  <Shape> 

    <Arc><X1>1</X1><Y1>1</Y1><X2>99</X2><Y2>99</Y2><Pen><Width>2</Width></Pen></Arc> 

    <Arc2><X1>4</X1><Y1>4</Y1><X2>96</X2><Y2>96</Y2><Pen><Width>0</Width></Pen></Arc2> 

    <Line1><X1>5</X1><Y1>34</Y1><X2>95</X2><Y2>34</Y2><Pen><Width>2</Width></Pen></Line1> 

    <Line2><X1>5</X1><Y1>66</Y1><X2>95</X2><Y2>66</Y2><Pen><Width>2</Width></Pen></Line2> 

    <Line3><X1>5</X1><Y1>32</Y1><X2>95</X2><Y2>32</Y2><Pen><Width>0</Width></Pen></Line3> 

    <Line4><X1>5</X1><Y1>68</Y1><X2>95</X2><Y2>68</Y2><Pen><Width>0</Width></Pen></Line4> 

  </Shape> 

  <Up2><X>50</X><Y>20</Y> <Font><Name>MS P ゴシック</Name><B>0</B><Size>10</Size></Font> </Up2> 
  <Up1><X>50</X><Y>32</Y> <Font><Name>MS P ゴシック</Name><B>1</B><Size>Auto</Size></Font> </Up1> 
  <Date><X>50</X><Y>57</Y> <Font><Name>Arial</Name><B>1</B><Size>10</Size></Font> </Date> 
  <Low1><X>50</X><Y>70</Y> <Font><Name>MS P ゴシック</Name><B>1</B><Size>Auto</Size></Font> </Low1> 

</Profile> 
 

   概要 デフォルト値 
Shape Arc X1,Y1,X2,Y2 円の座標 0,0,99,99 
  Pen:Width 線の太さ 2 
 Arc2 X1,Y1,X2,Y2 円の座標（２重線用） 4,4,96,96 
  Pen:Width 線の太さ 0 
 Line1 X1,Y1,X2,Y2 上の線の座標 5,34,95,34 
  Pen:Width 線の太さ 2 
 Line2 X1,Y1,X2,Y2 下の線の座標 5,66,95,66 
  Pen:Width 線の太さ 2 
 Line3 X1,Y1,X2,Y2 上の線の座標（２重線用） 5,32,95,32 
  Pen:Width 線の太さ 0 
 Line4 X1,Y1,X2,Y2 下の線の座標（２重線用） 5,68,95,68 
  Pen:Width 線の太さ 0 
Up2  X,Y 上段の上の文字列の座標 50,20 
 Font Name 上段の上の文字列のフォント名 MS P ゴシック 
  B 上段の上の文字列が太字か否か 

１：太字 ０：太字でない 
0 

  Size 上段の上の文字列の文字サイズ 
Auto: 文字数から自動設定 

Auto 

Up1  X,Y 上段の下の文字列の座標 50,32 
 Font Name 上段の下の文字列のフォント名 MS P ゴシック 
  B 上段の下の文字列が太字か否か 

１：太字 ０：太字でない 
0 

  Size 上段の下の文字列の文字サイズ 
Auto: 文字数から自動設定 

Auto 

Date  X,Y 中段（日付）の文字列の座標 50,57 
 Font Name 中段（日付）の文字列のフォント名 Arial 
  B 中段（日付）の文字列が太字か否か 

１：太字 ０：太字でない 
0 
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  Size 中段（日付）の文字列の文字サイズ 
Auto: 文字数から自動設定 

Auto 

Low1  X,Y 下段の文字列の座標 50,70 
 Font Name 下段の下の文字列のフォント名 MS P ゴシック 
  B 下段の下の文字列が太字か否か 

１：太字 ０：太字でない 
0 

  Size 下段の下の文字列の文字サイズ 
Auto: 文字数から自動設定 

Auto 

 
 
丸輪郭線を２重線表示するために Arc2 が追加されています。 
また、上段下段の区切り線を２重線にするために Line3,Line4 が追加されました。 
全ての輪郭線 Arc,Arc2,Line1,Line2,Line3,line4 は太さを設定するためにタグ<Pen><Width> 
を持っています。このタグ<Pen><Width>を０（ゼロ）にすることにより、「認印」のような
日付の無い印鑑も出来るようになりました。 
 
プロファイルは既存のものを修正することも出来ますし、いくつでも作成することができます。
数字は全て半角を用いてください。フォントは間違いやすいので注意して記述してください。 
お使いのパソコンで用いることの出来るフォントは [スタートメニュー : コントロールパネ
ル : フォント] で確認することが出来ます。また、日付印ぺったんインストールディレクト
リ下のフォルダー ptdata 中のファイル「フォントリスト.txt」にはWindowsで用いることの
出来る一般的なファンとがリストされています。ご利用ください。 
 
なお、フォントの記述が間違っている場合、Windows がかってにフォントを選択します。フ
ォントを変えても印影中のフォントが変わらない場合は、フォント名を再確認してください。 
 
Ver5.6.1.4 にはデフォルトのプロファイル tkprf_ptn_default.xml の他にいくつかのサン
プルプロファイルが付属しております。 
 
プロファイル名 説明 例 

tkprf_ptn_default.xml デフォルトのプロファイ
ル 

 

tkprf_ptn_wline.xml 外丸２重 

 
tkprf_ptn_wline2.xml 外丸２重、区切り線２重 

 
tkprf_ptn_mitome.xml 認印、日付無し 

 
tkprf_ptn_mitome3.xml 認印、日付無し、３文字 
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プロファイルはインターネットエ
クスプローラ Ver6 で表示できま
す。 
 
メモ帳で編集した場合は、編集後
に IE(インターネットエクスプロー
ラ)で開いてみることをお勧めいた
します。タグ構造が壊れた場合は
IE がエラーを出しますのでチェッ
クになります。 

 
図 メモ帳で表示するよりは IEで表示したほうが見やすい 
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１０. ログの出力 

押印すると押印履歴がログファイルに出力されます。 
文書番号、押印日、押印時間、承認者、所属、コメントを出力します。 
ログファイル名はデフォルトでは C:¥hanko¥hankolog.txtです。 
ログの出力形式は CSV形式です。デリミタはパイプ（縦棒）とカンマが選択できます。 
 
ログ出力の設定  
pettanin.exe を起動し、メニュー[オプション] -> [ログファイル...]を選択します。 
 

 
 
ログには押印時に押印ダイアローグに入力した情報が出力されます。 
 
文書番号,押印日,押印時刻,押印者の氏名,押印者の所属,コメント,Windowsログイン
ユーザ名,コンピュータ名 
・  
 
 
 
パイプ形式のログ例  
ISO9000-001|1999/5/16|7:58| 佐 藤 | 情 報 シ ス テ ム 部 | コ メ ン ト
No20|Tororo|DELLG1|  
 
ＣＳＶ（カンマ）形式のログ例 
ISO9000-001,1999/5/16,8:7, 鈴 木 , 情 報 シ ス テ ム 部 , コ メ ン ト No20, 
Tororo,DELLG1, 
 

 
ログファイルを出力するには[Output Log]にチェックを付けます。  
ログファイル名を変更するにはボタン[Ref]をクリックします。 
 
 
Ver5.6.1.5 からログに押印時のWindowsログインユーザ及びコンピュータ名が出力されるよ
うになりました。
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１１．未押印ぺったんオブジェクト 
 
日付印ペッタンは押印しない状態であらかじめワードなどで作成したフォーム（様式）に埋
め込んでおき、押印の際にはこの埋め込んでおいた日付印ペッタンをダブルクリックするとい
う方法があります。 
 この場合、サイズは１６ＭＭになります。 
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１２．自動押印 

押印ダイアローグを表示せずに押印できます。 
 
自動押印機能を使用するにはパスワード保存機能を用い、あらかじめパスワードを設定してお
きます。 
 
12-1.自動押印の設定 
日付印ペッタン が起動された状態で、 
メニュー[オプション:設定]をクリックします。 
 
自動押印チェックボックスにチェックを入れ
れば、承認ダイアローグの表示なしに押印さ
れます。 
 
注意）自動押印されるのはパスワードの保存機
能を用いてパスワードが保存されている場合の
みです。パスワードが保存されていない、パス
ワードが一致しない場合は承認ダイアローグが開きます。 
 

12-2.自動押印の解除 
日付印ペッタン が起動された状態で、メニュー[オプション:設定]をクリックします。 
自動押印チェックボックスのチェックをはずせば、承認ダイアローグが表示されるようになり
ます。 
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Appendix A ライセンスIDとぺったん ID 

ライセンス IDは基本ユーザライセンスをご購入の方にお送りしております。 
一方、ぺったん IDはパーソナルユーザライセンスご購入の方にお送りしております。 
体験モードでぺったんを登録した場合はぺったん IDは 0000-0000-0000-0000 に、ラ
イセンス IDは 「体験版」 になります。 
 
体験モードの場合 
上段と下段の文字数の合計が全角２文字以内の場合はぺったんIdとして 0000-0000-0000-0000  
を入力すれば登録することができます。この場合、インデックスファイルとぺったんファイル
がどうなるか下に例を示します。 
 
体験版の例のインデックスファイル例 
[安部] 
Data=<Petfile>安部.ptn</Petfile><Profile>tkprf_ptn_default.xml</Profile> 
<Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>体験版</LicenseId><Hash>JC2JDWYW</Hash> 

Name=部 
Section=<Up1><Text>安</Text></Up1><Up2><Text></Text></Up2> 
Password1=JB5BSRNP 
Password2=TeHc[B 
Hash=By81nw 
安部.ptn 
<Pettan><Up1>安</Up1><Up2></Up2><Down>部</Down> 
<PettanID>0000-0000-0000-0000</PettanID><PHash>WYZJZDR6</PHash></Pettan> 
<Profile>tkprf_ptn_default.xml</Profile><Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>体験版</LicenseId><Hash>JC2JDWYW</Hash> 
 
登録されるライセンス IDは 体験版 となります。また、ぺったん IDは 0000-0000-0000-0000 
となります。 
 
パーソナルライセンスの場合 
上段と下段の文字数の合計が全角２文字を越える場合はぺったん Id と登録キーが必要になり
ます。インデックスファイルとぺったんファイルがどうなるか下に例を示します。 
 
パーソナルライセンスの場合のインデックスファイル例 
[田中] 
Data=<Petfile>田中.ptn</Petfile><Profile>tkprf_ptn_default.xml</Profile> 
<Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>Personal</LicenseId><Hash>C2VXZP9F</Hash> 
Name=中 
Section=<Up1><Text>田</Text></Up1><Up2><Text></Text></Up2> 
Password1=CFXMSRNP 
Password2=TeHc[B 
Hash=BCxrtN 
田中.ptn 
<Pettan><Up1>田</Up1><Up2></Up2><Down>中</Down> 
<PettanID>0000-1234-1234-1234</PettanID><PHash>4Y7YVYCV</PHash></Pettan> 
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<Profile>tkprf_ptn_default.xml</Profile> 
<Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>Personal</LicenseId><Hash>C2VXZP9F</Hash> 
 
パーソナルらいセンスの場合、登録されるライセンス IDは personal となります。 
 
基本ライセンスユーザの場合 
ライセンス ID及びぺったん IDには同じものが入ります。 
 
基本ライセンスユーザの場合のインデックスファイル例 
[久保田早紀] 
Data=<Petfile>久保田早紀.ptn</Petfile><Profile>tkprf_ptn_default.xml</Profile> 
<Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>とろろこんぶシステム工房</LicenseId><Hash>JTFX13WY</Hash> 

Name=早紀 
Section=<Up1><Text>久保田</Text></Up1><Up2><Text></Text></Up2> 
Password1=J22AWVUF 
Password2=TeHc[B 
Hash=B?jw;> 
 
久保田早紀.ptn 
<Pettan><Up1>久保田</Up1><Up2></Up2><Down>早紀</Down> 
<PettanID>とろろこんぶシステム工房</PettanID> 
<PHash>VZ1WC89V</PHash></Pettan> 
<Profile>tkprf_ptn_default.xml</Profile> 
<Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>とろろこんぶシステム工房</LicenseId><Hash>JTFX13WY</Hash> 
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Appendix B インデックスファイルのバージョンアップ方法 

日付印ぺったんを初めて使用する方はこの AppendixBは読み飛ばしていただいてかまいま
せん。以前のバージョン（Ver5.3.9.0 以前）を使用されている方は是非お読みください。 
 

B-1. インデックスファイルの違い 
このバージョンのインデックスファイル(デフォルトファイル名 index.dat) は Ver5.3.9 以
前のバージョンとは互換性がありませんのでご注意ください。 
 
Ver5.3.9 以前のバージョンでは全ての情報をインデックスファイルで管理していました。 
[安部] 
Data=<Profile>tkprf_ptn_default.xml</Profile> 
<Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>体験版</LicenseId><Hash>JC2JDWYW</Hash> 
Name=部 
Section=<Up1><Text>安</Text></Up1><Up2><Text></Text></Up2> 
Password1=JB5BSRNP 
Password2=TeHc[B 

Ver5.3.9 の インデックスファイル例 
 
Ver5.6.1 では日付印の情報は日付印個々のファイル（以降、ぺったんファイルと呼びます）
で管理します。下に例を示します。 
 
[安部] 
Data=<Petfile>安部.ptn</Petfile> ---- 個々の日付印のファイル名 
<Profile>tkprf_ptn_default.xml</Profile> 
<Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>体験版</LicenseId><Hash>JC2JDWYW</Hash> 

Name=部  --- Ver5.6.1 では使用しません。過去のバージョンとの互換性維持の為。 
Section=<Up1><Text>安</Text></Up1><Up2><Text></Text></Up2>--- Ver5.6.1 では使用しません。 
Password1=JB5BSRNP 
Password2=TeHc[B 
Hash=By81nw  --- ぺったんファイル(この例では安部.ptn)の書き換え防止のハッシュコード 
 

Ver5.6.1 の インデックスファイル例 
ぺったんファイル例 安部.ptn 
<Pettan><Up1>安</Up1><Up2></Up2><Down>部</Down> 
<PettanID>0000-0000-0000-0000</PettanID><PHash>WYZJZDR6</PHash></Pettan> 
<Profile>tkprf_ptn_default.xml</Profile><Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>体験版</LicenseId><Hash>JC2JDWYW</Hash> 
 

ぺったんファイル例(安部.ptn) 
 
Ver5.6.1 ではインデックスファイルにはぺったんファイル名<Petfile>安部.ptn</Petfile>を指
定しているだけです。上段下段などの全ての情報はぺったんファイルに保持しています。ただ
し、ぺったんファイルの情報からユニークに合成されるハッシュコードをインデックスファイ
ルに保持しますので、ぺったんファイルをメモ帳などで変更するとエラーとなり押印できない
ようになっています。 
インデックスファイルの内容とぺったんファイルの内容とで、同じ情報を重複して保持してい
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る部分があります。これは、Ver5.6.1 以前のバージョンとの互換性を保持するためです。 
 

B-2. インデックスファイルのバージョンアップ 
旧バージョンのインデックスファイルは Ver5.6.1 の管理ツールを用いて簡単にバージョンア
ップすることができます。バージョンアップする日付印を選択し、編集ダイアローグを開くだ
けです。以下、「安部」の例をとり、手順を示します。 

 
[安部] 
Data=<Profile>tkprf_ptn_default.xml</Profile> 
<Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>体験版</LicenseId><Hash>JC2JDWYW</Hash> 
Name=部 
Section=<Up1><Text>安</Text></Up1><Up2><Text></Text></Up2> 
Password1=JB5BSRNP 
Password2=TeHc[B 

旧バージョン(Ver5.3.9) の インデックスファイル例 
 
手順１）  Ver5.6.1 の日付印管理ツールを起動します。（図B-1） 
 
手順２）  バージョンアップする日付印、ここでは「安部」を日付印選択リストボックスから
選びます。 
警告が表示されますが、OKボタンをクリックします。（図B-２） 
 
手順３）  ボタン「修正(EDIT)」をクリックします。 
修正ダイアローグが表示されます。（図B-３） 
 
手順４）  パスワードを設定します。修正ダイアローグではパスワードは再設定となります。
英数字半角で任意の文字を設定してください。このパスワードは押印時に必要になりますので
忘れないようにメモしておいてください。（図B-３） 
 
手順５）  ボタン「OK」をクリックします。 
 

 

 

図B-1 日付印管理ツールを起動します。 図 B-2 Index ファイルが古いと警告が表示されます。 
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体験使用、あるいはパーソナルライセンスユーザの場合はぺったん ID 入力ダイアローグが開
きます。ぺったん IDと登録キーを入力してボタン「OK」をクリックします。（図B-４） 
基本ライセンスユーザの方は、このダイアローグは開きません。 
 

 

 

図B-3 修正ダイアローグ 図 B-4 ぺったんIDダイアローグ 
 
以上でインデックスファイルのバージョンアップは終了です。インデックスファイルとぺった
んファイル(安部.ptn)をメモ帳などで開いてみてください。下のようになっているはずです。 
 
[安部] 
Data=<Petfile>安部.ptn</Petfile>  
<Profile>tkprf_ptn_default.xml</Profile> 
<Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>体験版</LicenseId><Hash>JC2JDWYW</Hash> 

Name=部  --- Ver5.6.1 では使用しません。過去のバージョンとの互換性維持の為。 
Section=<Up1><Text>安</Text></Up1><Up2><Text></Text></Up2>--- Ver5.6.1 では使用しません。 
Password1=JB5BSRNP 
Password2=TeHc[B 
Hash=By81nw   
 

Ver5.6.1 の インデックスファイル例 
 
ぺったんファイル例 安部.ptn 
<Pettan><Up1>安</Up1><Up2></Up2><Down>部</Down> 
<PettanID>0000-0000-0000-0000</PettanID><PHash>WYZJZDR6</PHash></Pettan> 
<Profile>tkprf_ptn_default.xml</Profile><Shape><Size><X>19</X><Y>19</Y></Size></Shape> 
<Date><Format>YYYY.MM.DD</Format></Date> 
<LicenseId>体験版</LicenseId><Hash>JC2JDWYW</Hash> 
 

ぺったんファイル例(安部.ptn) 
 
 
おわり 

 


